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オシロスコープと信号処理 [オシロスコープ編]テキスト  

             （最終改訂 2016/05/27） 

 

実験の目的 

情報学実験Ⅰ課題②（以下「課題Ⅰ②」と言い、同テキストは「Ⅰ②テキスト」と言う。他の課題に

ついても同様に表記する。）及び課題Ⅰ⑦で使用した PC のサウンド機能について（註参照）、その特性

を周期現象の電気信号波形を観測する基本的な計測装置であるオシロスコープ（課題Ⅰ⑤で使用した

USB オシロスコープ 4424 および同タイプの 2 チャンネルモデル 4224）を用いて計測して確認すると

共に、オシロスコープの操作法及び機能を理解する。課題Ⅱ④「音声分析」の準備として信号の時間領

域と周波数領域での観測である波形とスペクトルの関係について理解を深めることも目的とする。 

 

註：2015 年度までは、測定対象を各自が使用するメモリプレーヤの再生特性とし、メモリプレーヤを

用意できない場合に PC のサウンドカードの特性を計測することとしていた。2016 年度は MATLAB に

よる「信号処理編」に重点を移し、作業手順の少ない PC のサウンドカードの特性計測に変更し、標本

化における帯域制限の効果の確認を追加するとともにテスト用信号ファイルの生成のため事前に

MATLAB の作業を必要とする内容に改めている。 

 

注意 

本テキストでは実験を行う上で必要な項目について記述しており、オシロスコープの詳細については

参考資料および電気・電子計測の教科書に譲る。課題Ⅱ②は、オシロスコープ編と信号処理編と併せて

「オシロスコープと信号処理」1 課題としており、オシロスコープ編の作業は 1 コマ目（2016 年度は

2015 年度と同様、コンピュータ科学科では 1 限、情報デザイン学科では 3 限）で終了する。オシロス

コープ編では、Local PC（ローカル PC）でログインする【事前準備のテスト用信号ファイルの作成及

び 2 コマ目の信号処理編では、MATLAB のインストールされている Virtual Desktop（仮想デスクトッ

プ）でログインすることに注意】。 

「オシロスコープ編」の作業は再実験の対象ではなく、10 月 7 日の再実験日には「信号処理編」の

みを行う。レポートで「オシロスコープ編」の報告に相当する代替項目については本テキスト末尾の備

考 p. 22「レポート作成について」を参照のこと。 

 

参考資料 

 本課題の使用機器ではないが、オシロスコープの機能と計測の基本については次の資料が参考となる。 

 

オシロスコープのすべて 

http://jp.tek.com/dl/XYZs_of_Oscilloscopes_03Z-8605-6.pdf 

いまさら聞けない！オシロスコープ入門 

http://jp.tek.com/dl/MONOist_ScopeXYZ_3GZ-24864-0.pdf 

 

実験ノート以外に用意するもの 

USB メモリ：波形ファイル（オシロスコープのバッファに取込まれたデータのイメージ）、画像ファ

イル（オシロスコープウィンドウの画面キャプチャ）の保存用。 

 

事前準備 

情報学実験のページから MATLAB_sample.zip をダウンロードして、実験手順 0 節（p. 3）の手順に

http://jp.tek.com/dl/XYZs_of_Oscilloscopes_03Z-8605-6.pdf
http://jp.tek.com/dl/MONOist_ScopeXYZ_3GZ-24864-0.pdf
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従いテスト用信号ファイルを生成しておく。使用機器・部品類のオシロスコープ、ブレッドボード、ジ

ャンプワイヤ付プラグは、3 個のテスト用信号ファイルが生成済であることを実験ノートで確認して手

渡すので、各信号ファイルのプロパティの作成日時（秒まで）、サイズ（バイト数）を実験ノートに記

録しておくこと。生成したファイルの授受は不正行為であり、固く禁ずる。 

必ず、本テキストに最後まで目を通して、本課題で必要なデータの意味を理解し、全体の作業の流れ

を把握しておく。USB オシロスコープ用のソフトウェア PicoScope 6 は PicoScope 4224/4424 本体を

接続せず、デモモードで動作するので 3 節（p. 7）の波形表示とスペクトル表示の切替え、レンジ、ト

リガーの設定について操作の予習を強く推奨する。本課題の作業では準備課題である課題Ⅰ⑦の理解が

前提となっており、課題Ⅰ⑦で表紙の交付を受けられなかった学生は十分に復習をしておくこと。 

 

使用機器・部品類 

   USB オシロスコープ：PicoScope 4224（USB ケーブル、プローブ 2 本付）または同 4424（USB ケ

ーブル、プローブ 4 本付：ここではプローブ 2 本のみを使用する）。マニュアル、ユーザーガイドのダ

ウンロード URL は次の通りである。 

PicoScope 4000 Series Programmer's Guide 

http://www.picotech.com/document/pdf/ps4000pg.en-8.pdf 

PicoScope 4000 Series User's Guide  

https://www.picotech.com/download/manuals/ps4000.en-7.pdf （2015/12/09 版） 

PicoScope 6 ユーザーガイド【注意参照】 

https://www.picotech.com/download/manuals/PicoScope6UserGuideJA.pdf （2014/09/02 版） 

PicoScope 6 User's Guide  

https://www.picotech.com/download/manuals/picoscope6-oscilloscope-software-users-guide.pdf 

（2016/02/22 版） 

PicoScope 6 Self-Help Guide 

http://www.picotech.com/document/pdf/picoscope6-self-help-guide-1.pdf 

PicoScope 6 Training Manual  

https://www.picotech.com/download/manuals/PicoScope_6_Training_Manual.pdf （2014/10/01

版） 

   ブレッドボード（課題Ⅰ②で使用した共振ユニットに 1kΩ抵抗 2 個を追加実装したもの） 

白赤黒ジャンプワイヤ付 3.5φ3 極プラグ（課題Ⅰ②で PC への入力に使用したもの） 

 情報科学研究教育センターPC：Local PC でログインすることに注意。 

 

使用ソフトウェア 

 PicoScope 6 （PicoScope 4224/4424 本体を接続せず、デモモードで操作の予習が可能である） 

 https://www.picotech.com/downloads （PicoScope 6 ダウンロードページ） 

  https://www.picotech.com/download/software/sr/PicoScope6_r6_11_10_1.exe （2016/01/27 版） 

  https://www.youtube.com/channel/UC7ZYc00CrHgaxeHZGp3aQ9Q （解説動画サイト） 

 WaveGene/WaveSpectra （課題Ⅰ②、課題Ⅰ⑦で使用） 

http://efu.jp.net/ 

http://efu.jp.net/soft/wg/WG150.ZIP （オーディオ帯域信号発生器） 

http://efu.jp.net/soft/ws/WS151.ZIP （リアルタイムスペクトラムアナライザ） 

 

注意 

 日本語のユーザーガイドには訳が正しくない部分があり、日本語ガイドで不審に思った場合は迷わず

http://www.picotech.com/document/pdf/ps4000pg.en-8.pdf
https://www.picotech.com/download/manuals/ps4000.en-7.pdf
https://www.picotech.com/download/manuals/PicoScope6UserGuideJA.pdf
https://www.picotech.com/download/manuals/picoscope6-oscilloscope-software-users-guide.pdf
http://www.picotech.com/document/pdf/picoscope6-self-help-guide-1.pdf
https://www.picotech.com/download/manuals/PicoScope_6_Training_Manual.pdf
https://www.picotech.com/downloads
https://www.picotech.com/download/software/sr/PicoScope6_r6_11_10_1.exe
https://www.youtube.com/channel/UC7ZYc00CrHgaxeHZGp3aQ9Q
http://efu.jp.net/
http://efu.jp.net/soft/wg/WG150.ZIP
http://efu.jp.net/soft/ws/WS151.ZIP
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英文ガイドを参照すること。例えば残像モード（Persistence mode）の解説で、英文の“Red is used for 

the most frequent data, and less frequent data is represented successively by yellow and blue” 

(2016/02/22 版 p. 136)が、日本語版ユーザーガイドでは英語版旧版 p. 88 の内容を機械翻訳したと思わ

れる「色はデータの周波数を示しています。赤色は最も高い周波数、黄色は中間の周波数、青色は最も

小さい周波数のデータに使用されます。」（p.18）と記述され、意味が通じなくなっている。 

 

表紙交付基準 

「オシロスコープと信号処理」の表紙交付に関る課題完成の確認は 2 コマ目の「信号処理編」の作業

について行う。「オシロスコープ編」の作業では実験ノートによる課題完成の確認は行わないが、レポ

ートの記述に必要な計測結果は波形ファイル（必須：保存方法は p. 7 後述）及び画像ファイル（実験中

の保存を推奨）の形で保存しておくこと。実験手順中の記述の他、本テキスト末尾の備考 p. 22「レポ

ート作成について」を参照のこと。 

 

 

実験手順 

 

0．Virtual Desktop でログインし、MATLAB でテスト用信号ファイルを作成する。【事前準備として必

ず実験時限以前に行うこと】 

 

(0) 情報学実験のページから MATLAB_sample.zip をダウンロードして解凍する。 

解凍して得られる 14 個のファイルの内、オシロスコープ編の作業では MATLAB による信号生成プ

ログラム signal_gene.m のみを使用する。 

 

(1) MATLAB を開き、「現在のフォルダー」に信号生成プログラムをドラッグ&ドロップする。 

 スタートメニューからMATLAB R2014bを開く（図1左：MATLAB_sample.zip中の”補足.pdf”参照）。

MATLAB の最初の起動（1 年前期必履修科目「情報学基礎セミナー」の実習）でユーザのドキュメン

トライブラリに MATLAB フォルダ（S:¥Documents¥MATLAB）が作成され（スタートメニューの「個

人用フォルダーを開きます。」からエクスプローラを開いた場合、「▼ユーザ名▼マイドキュメント▼

MATLAB」と表示される）、以後に設定を変更していなければこれが既定の「現在のフォルダー」であ

る（図 1 中はこれが空の場合の例）。「現在のフォルダー」ウィンドウに signal_gene.m をドラッグ&ド

ロップする（図 1 右）。 

 

 

図 1 MATLAB を起動し、「現在のフォルダー」に signal_gene.m をドラッグ&ドロップする 
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(2) MATLAB で信号生成プログラムを実行する。 

 「現在のフォルダー」に signal_gene.m が表示されていることを確認し（p.3 図 1 右）、コマンドウィ

ンドウに signal_gene と入力し（拡張子は付けない。図 2 左）、Enter を押下する。約 20 秒後（実行環

境に依存する）、「現在のフォルダー」に新たに 1kHz_0dB.wav、20kHz_0dB.wav、fast_sweep.wav の

3 個のファイルが表示され（図 2 中）、「Figure 1」ウィンドウに高速スイープ信号の 1 周期分の波形が

表示されれば（図 2 右）実行完了である。 

 

 

図 2 信号生成プログラムを実行し、3 個の音声ファイルが生成されたことを確認する 

 

(3) 生成された音声ファイルのプロパティを記録する。 

 「現在のフォルダー」に 3 個のファイルが作られたことを確認して（図 2 中）各ファイルのプロパテ

ィ（「全般」の頁）のキャプチャを取り、作成日時（秒まで）、サイズ（バイト数）を実験ノートに記録

して MATLAB を閉じる。オシロスコープ他の機材はこの記録を確認の上で手渡すので記録を忘れない

こと。スタートメニューの「個人用フォルダーを開きます。」からパスをたどる必要は無く、「現在のフ

ォルダー」ウィンドウでファイル名を右クリックし「エクスプローラに表示」を選べばよい。生成され

たファイルの USB メモリ等への保存も「現在のフォルダー」からドラッグ&ドロップで行える。 

 

 signal_gene.m の実行により作成されるテスト用信号ファイルの内容は以下の通りである。 

 

1kHz_0dB.wav 

ビット深度 16 ビット、標本化周波数 44.1kHz のステレオ音声ファイルで 1000.01Hz、0dBFS 正弦

波が左右同相で無音区間を含め 30 秒記録されている。無音区間、立上り・立下り区間（p. 23 図 33 参

照）の長さは DENON のテスト信号に揃えている。立上り区間終了後、約 3.98 秒で 65535 通り（p. 5

註 1 参照）の全てのディジタル値を取る。 

20kHz_0dB.wav 

ビット深度 16 ビット、標本化周波数 44.1kHz のステレオ音声ファイルで 19999.99Hz、0dBFS の正

弦波が左右同相で無音区間を含め30秒記録されている。無音区間、立上り・立下り区間の長さはDENON

のテスト信号に揃えている。立上り区間終了後、約 5.11 秒で 65535 通りの全てのディジタル値を取る。 

fast_sweep.wav 

ビット深度 16 ビット、標本化周波数 44.1kHz のステレオ音声ファイルで 50ms の無音区間に続いて

-15dBFS（第 1 波のみ 2dB ブーストされ -13dBFS。このため、第 1 波と第 2 波との間で微分は不連
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続になっている）の正弦波の瞬時周波数を 20Hz から 20kHz まで指数関数的に変化させ 200ms でスイ

ープしている（約 10ms で 1 オクターブ）。250ms を 1 周期として（p. 4 図 2 のグラフは青が左、赤が

右）、これを 480 回繰返し左右逆相（註 2 参照）で 120 秒記録されている。振幅、微分が不連続となる

第 1 波のブースト、スイープ速度は NAB のテスト信号に揃えている。 

 

註 1：音響機器の計測で基準となる 1kHz の正弦波は標本化周波数 44.1kHz では 10 波 441 標本の繰返

しとなり、高々441 通り（初期位相 0 で 441 通り、π/2 では 221 通り）のディジタル値しか取り得な

い。全てのディジタル値を取る様に 1kHz_0dB.wav および 20kHz_0dB.wav では半端な周波数を採用

している。取り得るディジタル値の個数の違いは WaveSpectra での分析で実際にノイズと歪率の違い

となって現れる（図 3 に 1000Hz と 1000.01Hz の 16 ビット最大振幅の正弦波の歪率の違いを示す）。

課題Ⅰ⑦で見た様に、ディジタルオーディオで用いられている 2 の補数表現では 16 ビットで表せる数

の範囲は -32768～+32767であるが、電気信号の極性を反転したときに符号反転のできない -32768

は使用せず、データは 65535 通りとなる。 

 

註 2：第 1 波だけ 2dB 高く記録することによりオシロスコープでトリガーをかけられるが（p. 15 図 22

参照）、極性が異なる音響機器でも何れかのチャンネルでトリガーがかかる様に左右逆相で記録してい

る。再生系が本来の極性であれば右チャンネル、逆であれば左チャンネルをトリガーのソースとする。 

 

 

図 3 WaveGene で生成した最大振幅の正弦波：1000Hz（左） 1000.01Hz（右） 

 

 

１．Local PC でログインし、再生の既定の形式を変更する。 

 

 課題Ⅰ②で見た通り（Ⅰ②テキスト p. 4）、Windows7 のオーディオエンジンでは標本化周波数変換

への十分な対応がされておらず（変換精度はごく初期の DAC レベル）、PC のサウンドカードから出力

する場合、その設定を再生する音声ファイルの標本化周波数に合せる必要がある。 

本課題４節で使用するテスト用信号ファイルは標本化周波数 44.1kHz で作成されており、WaveGene

の生成信号を再生する５節、６節も WaveGene の「ｻﾝﾌﾟﾘﾝｸﾞ周波数」を「44100」（Hz）に設定して行

う。これに合せるため、課題Ⅰ②及び課題Ⅰ⑦後半音声ディザ編と同じく、コントロールパネル→個人

設定→サウンド→再生→スピーカーのプロパティ→詳細で既定の形式を「16 ビット、44100 Hz（CD

の音質）」に変更する（p. 6 図 4）。 
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図 4 再生の既定の形式を 16 ビット、44100 Hz（CD の音質）に変更する 

 

 

２．USB オシロスコープを PC に接続し、ブレッドボード上に計測回路を構成する。 

 

本課題では音声出力電圧計測用の負荷抵抗として 1kΩの抵抗 2 個（左右両チャンネル用）が実装さ

れたブレッドボード（図 5 左：課題Ⅰ②で使用した共振ユニットに赤枠部分の抵抗を追加している）を

用いる（註参照）。図 5、p. 7 図 6 中のブレッドボードとオシロスコープは説明用の個体で、シリアル番

号を記載したラベルは貼られていない。 

 

註：2015 年度までは、先バラの 3.5φ3 極プラグ付ステレオ音声ケーブルに負荷抵抗をはんだ付したも

のを使用していたが、接続を確実にしてノイズの混入を抑える目的で変更している。負荷抵抗は、ブレ

ッドボードの文字の向きに従い、左端（1 列）を左チャンネル用、右端（30 列）を右チャンネル用とし、

f 行と GND 行（黒のライン）に挿している。 

 

 

図 5 負荷抵抗を実装したブレッドボード（左） 計測装置全体（右） 

 

  USB ケーブル（オシロスコープのケースに収納）の Type A、Type B コネクタをそれぞれ PC 前面の

USB ソケットとオシロスコープ背面の USB ソケットに挿し、2 本のプローブのコネクタ（挿した後、

右に回してロックするバヨネット式）をオシロスコープ前面の BNC 端子（図 5 右の通り、4 チャンネ

ルモデル 4424 では左側の 2 個を使用し、右側の C チャンネル、D チャンネルは使用しない）につなぐ。 

オーディオでは、ステレオ音声ケーブルの色について白が左、赤が右の規約で、チャンネル順序は左、
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右の順（PCM データの伝送順も左が先で、wav ファイル中のデータも左データのアドレスが若い）と

なっている。したがって、計測回路の構成は次の通りとなる（図 6 左、中）。短絡事故を防ぐため、ジ

ャンプワイヤをブレッドボードに挿した後に 3.5φ3 極プラグを挿すこと（抜く時は逆にプラグ、ジャ

ンプワイヤの順）に注意する。 

(1) 黒のジャンプワイヤをブレッドボード下部の黒のライン（どの穴でもよい）に挿す。 

(2) 白と赤のジャンプワイヤを、それぞれブレッドボード上段（ａ~ｅの何れか）の 1 列、30 列に挿す。 

(3) 3.5φ3 極プラグを PC 前面の音声出力ジャック（下側のジャックでヘッドホンの絵が描かれている）

に挿す。 

(4) 抵抗の下側（黒ラインに挿された側）のリード線をプローブのみの虫クリップで挟み、プローブの

フックを抵抗の上側（ｆ行に挿された側）のリード線に引っ掛ける。1 列の抵抗が A チャンネル、30

列の抵抗が B チャンネルである。 

 

 

    図 6 音声出力ジャック（左）、ブレッドボード（中）、プローブ減衰率切替 SW（右） 

 

プローブの減衰率切替 SW が×1 の側になっていることを確認する（図 6 右）。切替 SW の×10 位置

では信号電圧が 1/10 に減衰し感度が落ちる一方、オシロスコープから見た入力インピーダンスを大き

く、入力容量を小さくすることで高い周波数まで測定可能になる。切替 SW の付いたプローブは×10

での使用が基本であり、この設定で調整されているのが普通であるが、本実験で計測する信号の周波数

帯域では感度を落としてまで×10 を使用する利益は無いので×1 で使用する。 

 

 

３．USB オシロスコープアプリケーション PicoScope 6 を起動し基本機能を確認する。 

 

 本節の作業はオシロスコープ本体を接続せずデモモードで行え、個人所有の PC でも PicoScope 6 を

インストールすれば可能であり事前準備として予習しておくことが望ましい。4 節以降の作業では、保

存した波形ファイル（File→Save All Waveforms as… で拡張子 .psdata で保存する）があればオシロ

スコープ本体が無くても、デモモードで開いた PicoScope 6 で分析が可能（Measurements→Add 

Measurement で計測項目を追加、Tools→Maths Channels でチャンネル間の演算をすることもできる）

であり、管理者権限で使用できる PC があれば PicoScope 6 をインストールしておくことを推奨する。

本節の図は、p. 10 図 13、p. 11 図 14 を除きデモモードでの実行画面である。 

 

Windows プログラムメニューから Pico Technology の PicoScope 6 を選び起動する（p. 8 図 7 左）。
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オシロスコープ本体が接続されていない場合、No Device Found と表示されるので Yes をクリックし

（図 7 中）、モデルを選択する（図 7 右：ここでは 2 チャンネルモデル 4224 を選んでいる）。 

 

 

図 7 PicoScope 6 の起動（デモモードで 4224 モデルでのシミュレーション） 

 

図 8、9 に以下の操作で参照するメニューバーとツールバーを示す。メニューバーから、Tools→

Preferences→Regional & Language の頁の Language で ”Japanese(日本語)” を選べばメニューを日

本語に設定できるが、日本語ユーザーガイドも英語メニューに即して記述しており、また日本語ではメ

ニュー内の欄がずれることもあるので、ここでは英語メニューのまま使用する。図 8 は波形モードでの

ウィンドウ上端（スペクトルモードでは 2 段目の Capture Setup toolbar の表示が少し異なる）で、図

9 はウィンドウ下端の Triggering toolbar（両モードで表示は共通）である。 

 

図 8 波形モードのウィンドウ上端（上段から Menu bar、Capture Setup toolbar 、Channels toolbar） 

 

 

図 9 ウィンドウ下端 Triggering toolbar 

 

起動直後は時間領域での観測を行う波形モード（Scope Mode）で Capture Setup toolbar の波形アイ

コンが青表示（ ）され、Channels toolbar は A チャンネルが Auto（電圧レンジ自動）、B チャンネ

ルが off の状態で、A チャンネルのみ表示され、Triggering toolbar の Trigger は None（トリガーはか

かっていない）の設定である。 

 

デモモードでは既定で A チャンネルには振幅 800mV、周波数 1kHz の正弦波が入力され、時間レン

ジは 20ms/div（格子状の破線の横方向 1区間が 20msで画面全体では 10区間で 200ms）となっている。

波形をその周期に応じた適切な形で静止させて表示するため、時間レンジを変更しトリガーを設定する。

1kHz の正弦波を画面全体に 1 周期分表示するならば 100μs/div のレンジが該当するが、周波数計測を

自動で行うためには画面内に十分な数の繰返しが必要であり、Capture Setup toolbar の”Collection 

Time”を例えば 1ms/div として 10 周期分を表示する（p. 9 図 10(a)）。波形の詳細を見る場合は Capture 

Setup toolbar の Horizontal Zoom（ ）で時間軸を拡大する（p. 14 図 20 右参照）。波形を静

止させるため、Triggering toolbarの”Trigger”の右のボックスをNoneからAutoに変更する（図10(b)）。 
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図 10    (a) 時間レンジの設定                (b) トリガーの設定 

 

本課題の計測の対象はステレオ音声信号であり、Channels toolbar の”B”の右のボックスを off から

Auto（電圧レンジ自動）に変更し B チャンネル（右チャンネル）の信号波形も表示する（図 11）。既定

では、A チャンネルは青、B チャンネルは赤で表示されるが、各チャンネルの表示色はメニューバーの

Tools→Preferences→Colors で変更できる。 

 

 

図 11 B チャンネルを表示（電圧レンジ自動） 

 

デモモードの既定で B チャンネルには振幅 800mV、周波数 1.01kHz の正弦波が入力されており、A

チャンネルの信号とは周期が異なるので表示波形は静止しない。Triggering toolbar の”Trigger 

Channel”を既定の A から B に変更すれば B チャンネルの波形は静止するが、その場合は A チャンネル

の波形が静止しなくなる。 

トリガーと無関係に表示を静止させるには、PicoScope 6 がアクティブウィンドウの状態でスペース

バーを押下するかまたは Triggering toolbar の Stop ボタン（ ）をクリックして信号データのバッフ

ァへの取込みを停止する。取込みの再開はスペースバーを押下するかまたは Triggering toolbar 左端の

Go ボタン（ ）をクリックする。PicoScope 6 では一般的な映像・音声のプレーヤソフトと同様にス

ペースバーの押下で停止・再開の切替えができるが、実は Go ボタンも Stop ボタンもスペースバーと

同じオルタネイト型プッシュ SW の設定で、何れのボタンでも Go/Stop 動作が行える。 

Channels toolbar 右端の三角波アイコン（ ）はデモモードのみの機能で、各チャンネルに入力さ

れるシミュレーション信号の波形、周波数、電圧等を自由に（”Arbitrary…”を選択して波形エディタに

よる任意波形の入力も可）設定できるので興味のある人は信号を切替えて観測していただきたい。 

 PicoScope 6 ではメニューバーの Measurements→Add Measurement で対象チャンネルと計測項目

（波形モードとスペクトルモードとで内容が異なる。波形モードの既定は A チャンネルの AC RMS）

を指定して信号の実効値、周波数等を自動的に計測することができ、４節（p. 13）以降の作業では設定

する計測項目がそれぞれ指定されている。p. 10 図 12 は B チャンネルの True RMS（定義通りの真の自

乗平均平方根）を指定する例である。 
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図 12  Add Measurement で計測項目を指定する（B チャンネル True RMS の例） 

 

既定計測項目の AC RMS は直流成分を除いた実効値で、PC のサウンドカードでは直流信号を出力で

きないため（註 1）、True RMS も AC RMS も同じ値となる。図 13 は、WaveGene で 1kHz -6dBの「ｻ

ｲﾝ波」に「ｵﾌｾｯﾄ」をフルスケールの 25%（生成信号の値域は、フルスケールを 1としてほぼ[-1/4, +3/4]

となる）に設定して PC のサウンドカードで再生した例で、正負のピークの絶対値は何れも約 0.8V、実

効値は True RMS、AC RMS の何れも約 0.56V となっている。 

p. 11 図 14 は、WaveGene の同じ信号を直流分をカットしない USB DAC で出力した例である。正負

のピークの絶対値の比、True RMS と AC RMS の比はそれぞれ 3：1、√3：√2（「ｻｲﾝ波」の振幅が-6dB

ではなく-20log102dBの場合の値）に近く、直流成分が正しく増幅されていることが分る（註 2 参照）。 

 

註 1：６節①（任意作業 p. 20）の手順で周波数特性を計測すると低域では 5Hz でも十分な応答がある

が、最終出力の直前で直流分をカットしているため fast_sweep.wav の再生では低域の特性が振動する

（後述 p. 15 図 22 参照）。 

 

註 2：オフセットを加えた正弦波を直流まで増幅できるヘッドホンアンプで再生した場合でも（発熱量

は True RMS で決るが）イヤホンの音圧は AC RMS で決る。 

 

 

図 13 オフセットを加えた正弦波（PC 内蔵サウンドカードの出力） 
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図 14 オフセットを加えた正弦波（直流増幅可能な USB DAC の出力） 

 

Capture Setup toolbar の をクリックし、周波数領域の観測を行うスペクトルモード（Spectrum 

Mode）に変更し、（図 15 左、中）、周波数レンジを本課題の周波数帯域に合せ 20kHz を選ぶ（図 15 右。

デモモードではプルダウンメニューの値が異なり 19.53kHz となる）。スペクトルモードでは電圧（縦

軸）は mV、V の単位ではなく対数スケールの dBu（通常のデシベル同様、電圧では基準に対する比の

常用対数の20倍である）で表示される。基準レベルの0 dBuは600Ωの負荷抵抗による消費電力が1mW

となる電圧で約 0.775V（√(3/5)＝(4/5)√(15/16)＝(4/5){1－(1/16)}^(1/2)≒4/5－1/40＝0.775）である。 

 

 

図 15 スペクトルモードに変更し周波数レンジを選択する 

 

 dBu は音響技術者、放送関係者にはなじみ深い単位であるが、スペクトルモードで、 （Spectrum 

Options）をクリックし、SI 単位系との対応が直感的な dBV（1V が基準の 0dBV）を選ぶこともでき

る（p. 12 図 16）。スペクトルモードでの電圧値は正弦波交流の実効値を示し、例えば波形モードでピ

ーク値が±1V の正弦波はスペクトルモードでは -3.01dBVとなる（0dBVではない）ことに注意する。 
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   図 16 スペクトルモードの Spectrum Options（単位に dBV を選択の例） 

 

スペクトルモードでも波形モードと同様にメニューバーの Measurements→Add Measurement で対

象チャンネルと計測項目（既定は A チャンネルのピーク周波数）を指定しての自動計測が可能で、図

17 は A チャンネルの全高調波歪を%表示で指定した例である。 

 

 

図 17  Add Measurement で計測項目を指定する（A チャンネル THD%の例） 

 

メニューバーの Edit→Notes（図 18 左）をクリックするとウィンドウ下端の Triggering toolbar の

上に注釈入力欄が開くので、必要な情報を入力しておくと画面をキャプチャして保存したファイルの整

理が容易である。Edit メニューの項目でクリップボードへのコピーには Copy as Image（ウィンドウの

描画部分のみコピー）、Copy as Text（図 18 右：波形情報をテキストデータとしてコピー）、Copy Entire 

Window as Image（図 18 中：描画部分だけでなく注釈行、計測結果もコピーされる。PicoScope 6 が

アクティブウィンドウの状態で Alt+PrtSc を押下した場合と同じ）の 3 種類があるが（註参照）、次に

述べる波形ファイルがあればこれを開いて後でコピーが可能であり、特にテキストデータのコピーは容

量が大きくなるので、作業結果の保存の優先順位は①波形ファイルの保存、②画面全体の保存とする。 

 

 

図 18 Edit メニュー項目：注釈入力（左） 画面全体コピー（中） テキストデータコピー（右） 

 

註：Copy as Image または Copy as Text を選択した場合、バッファへの信号取込みと画面の表示が停

止する。再開はスペースバーを押下するかまたは Triggering toolbar 左端の Go ボタン（ ）をクリッ

クする。 

 

 本節冒頭（p. 7）で述べた通り、オシロスコープで取得した信号データを File→Save All Waveforms 
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as… （註参照）で拡張子.psdata の波形ファイルとして保存しておけば、オシロスコープ本体が無くて

もこれを PicoScope 6 で開いて後で分析することができる（図 19）。保存先フォルダはユーザのドキュ

メントライブラリの Waveforms フォルダ（S:¥Documents¥Waveforms）で、既定のファイル名は年月

日と当日の通し番号をハイフンで繋げた yyyymmdd-xxxxであるが、レポート作成の便宜のため、内容

に即した識別しやすいファイル名を付けておくことを推奨する。 

 

註：Save All Waveforms as…ではバッファ中の取得データが全て保存される（Open…で開いたとき、

Capture Setup toolbar の Buffer Navigation toolbar を操作して別画面のデータ

を表示できる）のに対し Save Current Waveform as…では表示画面のデータのみが保存される。 

 

 

図 19 波形ファイルの保存（左、中）と読込み（右） 

 

 この他、本課題の作業に関係する操作として次のものがあり、詳細は User’s Guide（Pico Scope6 の

実行中にメニューバーの Help→User’s Guide…で確認できる）を参照されたい。 

● ウィンドウ画面の追加：右クリック→Add View で Scope/Spectrum/XY から必要な画面を選ぶ 

● ウィンドウ画面の削除：右クリック→Close View【表示画面が 1 個のみの場合はメニューに無い】 

● ウィンドウ画面中の表示チャンネルの指定：右クリック→Channels で表示するチャンネルをチェッ

クする【入力が Off のチャンネルはチェックボックスが表示されない】 

 

 以下、４節で PC のサウンドカードの出力周波数特性の概要を測定し、５節で標本化での帯域制限の

効果を確認する。６節の作業（再生特性の詳細）はレポートの作成において必須ではないが、時間に余

裕があれば取組んで頂きたい。コンピュータ科学科は 10 時 55 分、情報デザイン学科は 15 時 25 分ま

でにオシロスコープ、ブレッドボード、ジャンプワイヤ付プラグを返却する。 

 

 

４．テスト用信号ファイルを WaveSpectra で再生し、波形モードとスペクトルモードで観測する。 

 

 本節以下、６節までの作業ではタスクバーのスピーカーアイコンを操作して（またはコントロールパ

ネル→個人設定→サウンド→再生→スピーカーのプロパティ→レベルで）音量を最大（100）に設定す

る（註参照）。 

 

註：PC のサウンドカードの再生・録音双方の機能を使用する課題Ⅰ②及び課題Ⅰ⑦音声ディザ編５節

の作業では再生レベルを歪が出ない値に絞ったが、これは録音側アンプの許容入力の問題であり、実は

既定の形式を「16 ビット､44100 Hz（CD の音質）」に設定して標本化周波数 44100Hz、ビット深度 16

ビットの音声ファイルを再生した場合、再生単独では最大音量でも課題Ⅰ②での基準「THD+N が 0.1%

未満」（Ⅰ②テキスト p. 7）を満たしている。 

 

WaveSpectra を開き、事前準備で生成した 3 本のテスト用信号ファイルを順次ドラッグ&ドロップし

て再生し、File→Save All Waveforms as… で波形ファイルとして保存し【必須】、Edit→Copy Entire 
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Window as Image（または Alt+PrtSc）で画像をクリップボードにコピーして画像ファイル（拡張子

は.png が望ましい）に保存する【波形ファイルを保存してあれば事後に PicoScope 6 で開いて再現可能

ではあるが、作業中の保存を推奨する】。 

 

注意 

テスト用信号ファイルの再生には必ず WaveSpectra を使用することとし、Windows Media Player、

Adobe Audition 等のアプリケーションを使用してはならない。WaveGene の「ﾕｰｻﾞｰ波形」に登録して

開いても（ドラッグ&ドロップで Wave1 または Wave5 の登録画面が開くので「閉じる」をクリックす

ればよい）再生できるが、この場合は WaveGene の「振幅」、「ｻﾝﾌﾟﾘﾝｸﾞ周波数」、「ﾋﾞｯﾄ長」等の設定内

容に従った演算結果がサウンドカードに出力される。本節の測定では wav ファイルのヘッダ情報の設定

のまま再生するため必ず WaveSpectra で再生すること。 

 

Measurements→Add Measurement（p. 10 図 10、p. 12 図 17）で指定する計測項目は、波形モード

では AC RMS、Frequency、スペクトルモードでは Frequency at Peak、Total Harmonic Distortion 

(THD) %、Total Harmonic Distortion plus Noise (THD+N)（註参照）とするが、考察のため必要と考

える計測項目を独自に追加しても構わない。 

 

註：スペクトルモードの計測項目のメニューに THD は%表示と dB 表示の 2 種類があるが、THD+N は

dB 表示のみである。dB 表示の単位は dBc（decibels below carrier）を使用しており、例えば 0.1%歪

は -60dBcに相当する。 

 

● 1kHz_0dB.wav 

波形モードでは時間レンジを 1ms/div、スペクトルモードの周波数レンジは 20kHz とする。PC の内

部はオーディオ回路にとっては雑音源の巣窟であり、波形モードで Capture Setup toolbar の

Horizontal Zoom（ ）で時間軸を拡大して詳細波形を見ると、全体としてきれいな正弦波ではあ

るが随所に細かいスパイクノイズが乗っていることが分る（図 20 右）。 

 

 

図 20 1kHz_0dB.wav 波形モード 1ms/div 全体（左）、水平ズーム拡大表示（右） 

 

● 20kHz_0dB.wav 

波形モードでは時間レンジを 50μs/div、スペクトルモードの周波数レンジは 50kHz、100kHz の 2

通りの設定（音声信号の歪率計測では可聴周波数帯域 20kHz での分析が通常であるが、ここではサウ

ンドカードのノイズの様子を見るため可聴周波数よりも広い周波数帯域を設定）で観測する（p. 15 図

21）。 
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図 21 20kHz_0dB.wav スペクトルモード レンジ 50kHz（左）、レンジ 100kHz（右） 

 

● fast_sweep.wav（本信号は波形モードのみを観測） 

波形モードの時間レンジを 20ms/div とする。黄色のトリガーマーカー（ ）をドラグして波形を適

切な位置で静止させて 50ms の無音区間が画面外に出る様にする（図 22）。この信号は最初の 1 波だけ

他よりも 2dB（振幅では約 1.26 倍）レベルを高く記録されており、第 1 波の最大値と第 2 波以降の最

大値との間の値をトリガーレベルとする。低域では左右の信号で共に正と負のピークの絶対値に差が出

ているのは最終出力の直前で直流分をカットしている（周波数スイープにより信号の正の期間と負の期

間の長さが異なるため、積分したものが 0 とはならず直流成分が含まれる）ことによる。 

周波数の瞬時値は、スイープ開始箇所（波形画面の左端）が 20Hz で以下は 1 波当り 15loge10≒34.5

（Hz）増えるので最初のピーク（PC のサウンドカードは極性が逆なので左チャンネルで正）が約 28.6Hz、

次のピーク（同左チャンネルで負）が約 45.9Hz、ブースト無しの最初のピークが約 63.2Hz である。 

 

 

          図 22 fast_sweep.wav 波形モード 20ms/div 

 

 

５．WaveGene で帯域制限を設定して、パルスを波形モード、矩形波をスペクトルモードで観測する。 
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 WaveGene の「ｻﾝﾌﾟﾘﾝｸﾞ周波数」、「ﾋﾞｯﾄ長」、「ﾁｬﾝﾈﾙ数」がそれぞれ 44100、16、Stereo になってい

ることを確認する。本節で周波数の xxx は、学籍番号下 3 桁を十進数と見てこれに 280 を加えた数と

し、各個人で異なるので注意する。振幅を 0dB ではなく少し小さくしていることについて、Ⅰ⑦テキス

ト p. 4、WaveGene ヘルプ「使い方」の「帯域制限」の項を参照のこと。４節の作業と同様に、File→

Save All Waveforms as… で波形ファイルとして保存し【必須】、Edit→Copy Entire Window as Image

（または Alt+PrtSc）で画像をクリップボードにコピーして画像ファイル（拡張子は.png が望ましい）

に保存する 

 

① WaveGene の Wave1 の設定を波形：「ﾊﾟﾙｽ」、周波数：「xxx」Hz、振幅：「-3」dB、帯域制限：「な

し」と「加算」のそれぞれの設定で再生し、波形モードで計測する。 

 

  図 23 は、WaveGene で生成した周波数 500Hz（xxx がこの周波数に該当する学籍番号の学生はいな

い）、振幅-3dBパルスの音声ファイルをバイナリエディタ TSXBIN（Ⅰ⑦テキスト p. 21 参照）で表示

したものでファイル先頭の 44 バイトはヘッダ情報である。帯域制限「なし」で標本化された（WaveGene

のヘルプの表現では「単なる図形的な波形」）音声ファイルでは 32767*10^(-3/20)を整数化した

23197 が 1 周期中に 1 標本だけ現れる他は 0 である（図 23 左。黄枠は最初のパルス）。これに対し、帯

域制限「加算」で生成した音声ファイルは、Fourier 級数展開により Nyquist 周波数までの成分を加算

合成したもので（500Hz の場合、44 項の加算）、本来は無音の区間が正負の間で振動する標本値で埋め

られ振動はパルス位置から離れるに従って減衰している（図 23 右）。 

 

 

図 23 500Hz -3dBのパルスを 44100Hz で標本化：帯域制限無し（左）、加算合成帯域制限（右） 
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 理想化されたパルス（次項の②の矩形波でも同様である）の信号を有限な周波数帯域で伝送すること

は不可能であり、WaveGene の設定で帯域制限「なし」で標本化してもサウンドカードで出力する際に

帯域が制限されるため p. 16 図 23 左のディジタル値の通りに再現することはできない。 

図 24、25 は WaveGene で周波数 500Hz、振幅-3dBのパルスを帯域制限「なし」、「加算」で再生し、

波形モードで観測したものである。サウンドカードの再生出力の極性が逆で、p. 14 図 20 右と同様にス

パイクノイズが乗っていることが分る。図では、WaveGene の波形表示の時間軸部分を右クリックして

×20 の拡大を選択している。 

帯域制限なしで 1周期中に 1標本のみ非零である信号でもパルス前後の無音区間には減衰する振動が

現れるが（図 24）、WaveGene で帯域制限をすると振動がより大きく残る（図 25）ことが分る。 

 

 

図 24 パルスの再生例。内蔵サウンドカードは極性が逆になっていることが分る。 

 

 

図 25 WaveGene で帯域制限すると無音区間での振動が大きくなる 
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② WaveGene の Wave1 の設定を波形：「矩形波」、周波数：「xxx」Hz、振幅：「-3」dB、帯域制限：「な

し」と「加算」のそれぞれの設定で再生し、スペクトルモードで計測する。 

 

  図 26 は、WaveGene で生成した周波数 500Hz、振幅-3dB矩形波の音声ファイルを p. 16 図 23 と同

様にバイナリエディタ TSXBIN で表示したもので、帯域制限「なし」で生成した音声ファイルでは標

本値-23197と+23197とが半周期ずつ繰返される（図 26 左。黄枠は最初の半周期）。これに対し、帯

域制限「加算」で生成した音声ファイルは、Fourier 級数展開により Nyquist 周波数までの成分を加算

合成したもので（500Hz の場合、22 項の加算。信号を f (x )、周期を T とするとき f (x + T /2)＝-f (x )の

形の半周期平行移動すると符号が反転する信号では奇数次の高調波のみを持つためパルスの加算合成

とは項数が異なる）、不連続点の前後で振動している（図 26 右）。 

 

 

図 26 500Hz -3dBの矩形波を 44100Hz で標本化：帯域制限無し（左）、加算合成帯域制限（右） 

 

p. 19 図 27、28 は WaveGene で周波数 500Hz、振幅-3dBの矩形波を帯域制限「なし」、「加算」で

再生し、スペクトルモードで観測したものである。WaveGene で帯域制限をしない場合、信号周波数（こ

の例では 500Hz）の整数倍以外の成分が現れていることが分る。これは標本化の前に低域通過フィルタ

で Nyquist 周波数未満に帯域制限をしない場合に現れる偽信号で折り返し雑音と呼ばれる。帯域制限を

したものは図 28 右下の WaveGene の波形表示に見る通り、課題Ⅰ⑦の正弦波合成編（同テキスト p. 4

参照）で生成したと同様なフーリエ級数の形で（上限周波数 22050Hz でサウンドカードに）出力され

ている。 

 

レポートでは折り返し雑音について調べ、周波数が 441Hz（xxx がこの周波数に該当する学籍番号の

学生はいない）の場合と比較考察しなさい。 
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図 27 矩形波（帯域制限無し） 

 

 

図 28 矩形波（加算合成帯域制限） 

 

 

６．WaveGene で「ｻｲﾝ波」の周波数、振幅、出力ﾁｬﾝﾈﾙを変えて再生し、波形モードで観測する。 

 

 本節の作業は、周波数応答の詳細、チャンネル間クロストーク、小振幅特性、チャンネルバランスと

位相ずれを測定対象としており、レポートの作成において必須ではないが、時間に余裕があれば取組ん

で頂きたい。波形モードの時間レンジは、各周波数でそれぞれ 10 周期程度を表示する値に設定し、

Measurements→Add Measurement で指定する計測項目は、AC RMS、Frequency とする。 

 

 WaveGene の「ｻﾝﾌﾟﾘﾝｸﾞ周波数」、「ﾋﾞｯﾄ長」、「ﾁｬﾝﾈﾙ数」がそれぞれ 44100、16、Stereo になってい
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ることを確認する。Wave1 の波形を「ｻｲﾝ波」、Wave2～Wave8 の波形を「OFF」にする。 

 

① 周波数応答の詳細：Wave1 の設定を振幅：「0」dB、出力ﾁｬﾝﾈﾙ：「L+R」とし、「周波数/周期」を変

えて再生し、波形ファイルと画像ファイルを保存する。 

 

 片対数方眼紙に周波数を対数目盛、AC RMS を等間隔目盛を用いてプロットする。周波数は適切な値

を必要な個数選び観測する。音響測定の推奨周波数を定めた ISO266-1997 では、1/3 octave を近似す

る 1/10 decade の系列（R10 系列。註および p. 24 備考「整数デシベルの近似値について」参照）によ

る 1000Hz を基準とした中心周波数を示しており、20Hz～20kHz 間の公称周波数は次の通りである（単

位は Hz、赤字はオクターブ中心周波数）。20, 25, 31.5, 40, 50, 63, 80, 100, 125, 160, 200, 250, 315, 400, 

500, 630, 800, 1000, 1250,1600, 2000, 2500, 3150, 4000, 5000, 6300, 8000, 10000, 12500, 16000, 

20000。このリストの全ての周波数について観測する必要は無く、特性が急激に変化する帯域（低域、

高域の両端付近）を除きオクターブ間隔で十分である。下線を施したものは JEITA（電子情報技術産業

協会）の CD プレーヤ試験用信号の周波数に含まれる値で、JEITA では下線の値の他に 4, 8, 18000 の

3 周波数を加えている。 

 

註：210 ≒ 103であることから、10 octave ≒ 3 decade すなわち 1/3 octave ≒ 1/10 decade である。

正確な中心周波数の値（単位 Hz）は 1000×10^( i /10) （i は基準周波数を 0 とする整数指標）で与

えられるが、WaveGene の周波数の設定では公称周波数の値を用いて構わない。 

 

② チャンネル間クロストーク：Wave1 の設定を周波数：「1000」Hz、振幅：「0」dB とし、出力ﾁｬﾝﾈﾙ

を「L」/「R」と切替えて再生し、波形ファイルと画像ファイルを保存する。 

 

図 29左の例では、Rチャンネルのみに出力した0dBFSの信号が、Bチャンネルでは約 1.1V（AC RMS）

の正弦波、A チャンネルではピークで 30mV 程度の雑音として出力されている（A チャンネルの 1kHz

のパワーを知りたければスペクトルモードに切替える）。トリガーのソースは信号のあるチャンネル

（WaveGene の「出力ﾁｬﾝﾈﾙ」が「L」ならば A、「R」ならば B）を選ぶことに注意する。 

 

③ 小振幅特性：Wave1 の設定を周波数：「1000」Hz、出力ﾁｬﾝﾈﾙ：「L+R」とし振幅を切替えて（例え

ば -20dB、-40dB等）再生し、波形ファイルと画像ファイルを保存する。 

 

 PC のサウンドカードは雑音が多いため、-40dBFSの再生出力で既に雑音が正弦波（本来の応答）の

振幅を超え、計測項目で指定した周波数の自動計測ができないことを示している。WaveGene の波形は

縦軸も 20 倍に拡大している（図 29 右）。 

 

図 29 左：チャンネル間漏洩（R チャンネル信号）   右：小振幅特性（-40dBの例） 
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④ チャンネルバランスと位相ずれ：Wave1 の設定を振幅：「0」dB、出力ﾁｬﾝﾈﾙ：「L+R」とし、周波数

を「1000」（Hz）と「20000」（Hz）を切替えて再生し、波形ファイルと画像ファイルを保存する。 

 

メニューバーの Tools → Math Channels で減算 A-Bと乗算 A*Bにチェックを入れる（図 30）。減

算の意味は、再生出力で両チャンネルの位相が揃って（時間差が無い）かつレベルも揃って（音量差が

無い）いれば左右が同じ信号では結果が 0 となるので再生系のチャンネルバランスと位相ずれを一度に

チェックすることができる。乗算の意味は、位相が揃っていれば（左右のレベルに違いがあったとして

も）常に同符号（この場合左右同相の信号なので常に正）であることから位相ずれを単独でチェックで

きる（註参照）。別ウィンドウに表示したい場合は右クリックの Add View → Scope で波形モードのウ

インドウを追加し、右クリック→Channels で表示するチャンネル・演算結果を選ぶ。 

 

註：fast_sweep.wav で同様の演算（この信号は左右逆相なので減算の代わりに加算 A+B を選ぶ）を行

えばディジタルオーディオの全帯域の特性を一度に把握することができる。 

 

 

図 30  両チャンネルの信号の差と積とを求める 

 

1kHz の波形（図 31 左）では位相ずれは見られないが、20kHz の波形（図 31 右）では右チャンネル

（赤）が左チャンネル（青）よりも僅かに右にずれ（オシロスコープの両チャンネルの接続を入替えて

も PC の右チャンネル出力の波形が右にずれるのでオシロスコープのサンプリングによる誤差ではなく

PC のサウンドカードでのずれである）時間的に遅れていることが分る。 

 

 

図 31  チャンネルバランスと位相ずれ（水平ズーム拡大表示） 左：1kHz  右：20kHz 
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備考 

 

レポート作成について 

 

レポートには以下のものを必ず含めること 

 

● 0 節の作業で生成した 3 個のテスト用信号ファイルのプロパティ（「全般」の頁）のキャプチャ（作

成日時、サイズがレポート紙面で読取れるものであること） 

● 計測したサウンドカードの周波数特性を片対数方眼紙にプロットしたもの。対数目盛を横軸に用い周

波数を、等間隔目盛を縦軸に用い出力電圧をプロットする。６節①の作業をした人は再生周波数と計

測項目の AC RMS の値を使用し、６節を省略した場合は、４節の fast_sweep.wav の再生画面（p. 15

図 22）を元にプロットする（同図の説明で述べた通り、直流分のカットにより低域では正と負のピー

クの絶対値に差が出ており、本来の周波数特性について考察すること）。画面のキャプチャを実験作業

中に保存していなかった場合も波形ファイルを PicoScope 6 で開いて値を読取ればよい。読取りには

Capture Setup toolbar の Select（ ）、Windowed Zoom（ ）を活用のこと（図 32）。出力電圧は

読取った値を√2 で割った RMS 値をプロットし、第 1 波（2 箇所のピークは約 28.6Hz、約 45.9Hz）

についてはブースト（2dB：振幅で約 1.259 倍）分で割った値をプロットすることに注意する。片対

数方眼紙は、例えば次のサイトからダウンロードできる。 

方眼紙ダウンロードページ 

http://www.ahok.de/dt/#download 

片対数 A4 ダウンロード URL 

http://www.ahok.de/download/log-mm-paper.ps 

● 周波数 xxx Hz（xxx は学籍番号下 3 桁を十進数と見てこれに 280 を加えた数）、-3dBのパルスと矩

形波を再生して観測している画面キャプチャ（p. 17 図 24、25、p. 19 図 27、28 に相当するもので、

周波数がレポート紙面で読取れるものであること）。 

● 帯域制限「なし」で生成された周波数 441Hz と xxx Hz の矩形波の違いについての考察。 

 

 

図 32 PicoScope 6 で波形ファイルを開き Windowed Zoom、Select でピークの電圧を読取る 

 

 

10 月 7 日の再実験日（オシロスコープでの作業を行わない）のレポートおよび本実験レポートに上

記の内容を含められない場合は、相当する作業を以下に記す仕様の DTMF 信号を MATLAB で生成す

ることで替え、レポートには MATLAB のスクリプト、生成した音声ファイルを WaveSpectra で再生

中の画面キャプチャを含めること。 

 

http://www.ahok.de/dt/#download
http://www.ahok.de/download/log-mm-paper.ps
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DTMF 信号仕様： 

① 日本の電話機には実装されていない A,B,C,D の 4 個を含む 16 種類の符号を高群、低群から選んだ

周波数各 1 波の組合せで生成する（周波数の組合せは、例えば[1]を参照のこと）。 

② 高群の周波数のパワーを低群の周波数のパワーよりも（例えば）2dB 高くする。国内の規格（事業

用電気通信設備規則[2]）では「二周波電力差 ５ｄＢ以内、かつ低群周波数の電力が高群周波数の電力

を超えないこと」とのみ規定されているが、欧州の規格（[3]）では"The level of the higher frequency 

component of the signal shall be between 1 dB and 4 dB greater than the level of the lower 

frequency component"と定められており、国内で販売されている家庭用電話機の生成信号もこれに従っ

ている。 

③ 信号の立上りと立下りでは fade-in/out の処理をすること（註参照）。安価な電話機ではこの処理の

無いものもあるが、例えば NTT の公衆電話機の DTMF 信号では fade-in/out の処理がされている。 

 

[1] http://nemesis.lonestar.org/reference/telecom/signaling/dtmf.html 

[2] http://law.e-gov.go.jp/htmldata/S60/S60F04001000030.html 

[3]http://www.etsi.org/deliver/etsi_es/201200_201299/20123502/01.02.01_60/es_20123502v010201p.

pdf 

 

註：信号の立上り、立下りの fade-in/out の具体的な処理については情報学実験のページの本課題の項

にある signal_gene.m（1kHz_0dB.wav および 20kHz_0dB.wav は DENON のテスト信号に合せ

fade-in/out を指数関数で処理している。図 33）および Shepard_tone.m（半音上昇/下降の接続時の

fade-in/out をガウス関数で処理している。図 34）のソース中に示されているので参考にされたい。 

 

 

図 33 指数関数エンベロープによる 1kHz 正弦波の立上り、立下り 

 

 

 

図 34 ガウス関数エンベロープによる Shepard tone の立下り、立上り 

 

 

 同じ ”123A456B789C*0#D” の記号列をピーク標本値を-12dBFSに揃えて生成した DTMF 信号の

WaveSpectra によるスペクトルのピークを、Ⅰ②テキスト図 36、41 等と同様な画像処理で画面合成を

して比較したものを p. 24 図 35 に示す。fade-in/out の処理が不十分な場合、記号間の繋ぎ目で高群、

低群周波数以外の周波数帯にパワーが大きく残る。青はフリーの波形編集ソフト Audacity のツール、

http://nemesis.lonestar.org/reference/telecom/signaling/dtmf.html
http://law.e-gov.go.jp/htmldata/S60/S60F04001000030.html
http://www.etsi.org/deliver/etsi_es/201200_201299/20123502/01.02.01_60/es_20123502v010201p.pdf
http://www.etsi.org/deliver/etsi_es/201200_201299/20123502/01.02.01_60/es_20123502v010201p.pdf
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緑と赤はそれぞれ定評のある商品版波形編集ソフトのツールによるもので、黄が MATLAB でガウス関

数エンベロープで処理をして生成したものである。 

 

 

図 35  fade-in/out 処理の違いによる DTMF 信号 ”123A456B789C*0#D” のスペクトルのピーク 

 

 

整数デシベルの近似値について 

 

1/10 decade は 1dB のパワー比に当り、R10 系列に現れる公称周波数の（例えば 1250Hz～8000Hz

の 1000Hz に対する）比 1.25、1.6、2、2.5、3.15、4、5、6.3、8 はそれぞれ 1dB～9dB の近似値とな

っている。2 倍がほぼ 3dB に等しく 3 が 10 と互いに素であることから任意の整数デシベルの近似値は

2 の適当な冪乗を 10 の適当な冪乗で割ることにより得られる（1.28、1.6、2、2.56、3.2、4、5.12、6.4、

8）。10÷2＝5 より 5 倍がほぼ 7dB に等しく（7 も 10 と互いに素である）同様に 5 の適当な冪乗を 10

の適当な冪乗で割ることにより整数デシベルの近似値（1.25、1.5625、1.953125、2.5、3.125、3.90625、

5、6.25、7.8125）が得られる。 

両系列の近似値を 2 および 5 の冪指数で加重幾何平均したものが真の値であるが、これを加重算術平

均で近似すれば冪指数の和は 10 であり暗算で求められる。例えば 4dB（10^0.4=2.5118864315…）の

近似値は次の様に得られる。 

2 の冪から：2^8/10^2 = 2.56、5 の冪から：5^2/10 = 2.5、真の 4dB に対する相対誤差はそれ

ぞれの冪指数（8 と 2）に比例し、絶対誤差が 8:2 であると近似すれば 2.5+(2.56-2.5)*2/10 = 2.512

となる。 


